snrg.net
当前位置:首页 >> hADoop 2.8 可以用jDk1.8吗 >>

hADoop 2.8 可以用jDk1.8吗

没问题,jdk基本都是向下兼容的 我们在做dubbo接口开发是,要考虑jdk版本兼容的问题。如果是高版本的jre运行低版本jdk compile 的jar,根据java的向下兼容性,这个没有问题。但如果是低版本jre运行高版本的jdk compile的jar,会怎么样呢? 问题的...

重新配置jdk,配置完成后执行source /etc/profile,让配置文件立即生效,更多知识请查看《Linux就该这么学》,谢谢

你没有安装或者配置JAVA_HOME,请查看你的/etc/profile、hadoop/conf/hadoop-env.sh等需要配置JDK的文件。 另外一种可能是你安装配置了JDK,但是没有source /etc/profile,或者source后没有退出当前shell并重新登录来刷新JDK配置。

看样子应该是 JAVA_HOME 环境变量没配置好,你看看 hadoop-env.sh 那里是否配置JAVA_HOME环境变量?

bin/hadoop中接受的是namenode参数,不是Namenode,使用: bin/hadoop namenode -format 碰到这种情况,建议查看hadoop脚本或者代码。

Hadoop安装时需要指定HADOOP_HOME位置。可以使用如下三种export方法: 1、直接使用export命令 #export HADOOP_HOME=/home/sj/hadoop-x #export JAVA_HOME=/home/sj/java.x #export PATH=$HADOOP_HOME/bin:$PATH:$JAVA_HOME\bin # 看是否已经设好...

你好:我刚才上网查的资料,是可靠的,这个的话,Hadoop 2.6....Support JDK8

hadoop还是在linux上玩吧,弄个centos啥的 windows路径和linux的斜杠都不一样,不知道你的问题是不是因为这个

看看你/cygdrive/c/Program Files文件夹存在吗? 怀疑你的java_home路径写错了,确认是“/cygdrive/c/Program Files/Java/jdk1.7.0_67/jre/bin”吗?。“/cygdrive/c/Program”这个文件夹都不存在,下面的java路径更不正确了吧。

最下面那张图里环境变量设置的那一行多了一个$符号 export JAVA_HOME=/usr/java/jdk1.6.0_35

网站首页 | 网站地图
All rights reserved Powered by www.snrg.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com